Developer Guide to the WSDL Editor


Contributed by Jeff Stein
September 2007
This publication is applicable to NetBeans IDE 6.0.

This guide describes how to use the WSDL Editor component of NetBeans IDE 6.0 Beta 2. This component is included in the SOA functionality.

Contents

Tutorial Requirements

Before you proceed, make sure you review the requirements in this section.

Prerequisites

This tutorial assumes that you have some basic knowledge of, or programming experience with, the Java language and platform and the NetBeans IDE.

Software Needed for This Tutorial

Before you begin, you need to install the following software on your computer:

About the WSDL Editor

The WSDL Editor enables you to edit Web Services Description Language (WSDL) files.

WSDL is an XML-based language for describing web services. A WSDL file contains the following types of information:

The WSDL Editor supports version 1.1 of the WSDL specification.

The WSDL Editor provides the following views:

To create a WSDL file, you use a wizard. You must choose one of the following approaches:

top

Source View

In the Source view, the underlying XML source code appears. You can directly edit the XML.

The top of the Source Editor has a tab for each open document. Each tab shows the name of the document. If the document has been modified and has not been saved, then an asterisk (*) appears after the name. You can right-click a tab to access various commands.

A toolbar is located at the top of the Source Editor window.

Source code displayed in the Source Editor is syntactically colored.

Source view for the sample file SynchronousSample.wsdl

The Source Editor status line is located beneath the horizontal scroll bar. To toggle between insert mode and overwrite mode, use the Insert key.

top

Using Code Completion in WSDL Files

The WSDL Editor enables you to use the following types of code completion in WSDL files:

The code completion box can include elements and attributes that are specific to individual bindings, such as the FTP binding.

When the code completion box is visible, you can continue typing to fine tune the selection of items in the list. You can also use the mouse or navigation keys to scroll through the list.

To select an item in the list, do one of the following:

top

WSDL View

In the WSDL view of the WSDL Editor, the WSDL file appears as a tree component or a series of columns.

WSDL view for the sample file SynchronousSample.wsdl

The WSDL view has two subviews: tree view and column view. To switch between the subviews, use the buttons in the WSDL Editor toolbar.

The main nodes in the WSDL view correspond to the major elements in a WSDL file.

Some of the nodes in the WSDL view allow you to add extension attributes. Right-click the node and choose Add Extension Attribute. In the Add Extension Attribute dialog box, specify the name and namespace. Once you add the attribute, you can specify the value from the Properties window. To delete the attribute, right-click the node and choose Remove Attributes.

If you right-click a node and choose Go To > Source, then the Source view appears with the cursor positioned at the beginning of the component's block.

top

Configuring the Root Element

The root element of a WSDL file contains properties for the name of the WSDL file, the target namespace, the default namespace, and namespace prefixes. You can use the WSDL Editor to edit these properties.

To configure the root element:

  1. In the WSDL view, select the root node.
  2. If the Properties window is not visible, choose Window > Properties.
  3. Edit the name, target namespace, and default namespace as necessary.
  4. Edit the values of the namespace prefixes as necessary.

top

Importing XML Schemas Using the WSDL View

You can use the WSDL Editor to import one or more XML schema files into a WSDL file.

If an XML schema file cannot be imported, then the file is crossed out in the Add Import dialog box. This situation can happen for the following reasons:

The WSDL Editor allows you to import an XML schema file that is located in a different project. For more information, see the "About Cross-Project XML File References" topic in the IDE online help.

To import an XML schema:

  1. In the WSDL view, right-click the Types node and choose Add > Schema Import.
    The Add Import dialog box opens.
  2. Expand the By File or By Namespace node to navigate to and select the XML schema file.
  3. Click OK.
    The schema import node appears.

top

Adding Inline Schemas Using the WSDL View

The WSDL Editor provides support for the built-in simple types in W3C XML Schema. The built-in simple types include such types as string, date, and integer.

You can define your own data types by adding an inline schema. The WSDL Editor enables you to configure one or more schema elements and types, and to define the structure of the elements and types.

To add an inline schema:

To configure the global properties of the inline schema:

  1. If the Properties window is not visible, choose Window > Properties.
  2. Select the inline schema node.
  3. Perform one or more of the following optional tasks:
    • Specify a unique ID.
    • Specify whether locally declared attributes must be qualified with the namespace prefix.
    • Specify whether locally declared elements must be qualified with the namespace prefix.
    • Specify the default value of the block attribute, which controls the use of substitution.
    • Specify the default value of the final attribute, which controls the use of type derivation.
    • Specify the version of the schema.
    • Specify the target namespace of the schema.

To define the structure of the inline schema:

top

Importing WSDL Files Using the WSDL View

You can use the WSDL Editor to import one or more other WSDL files into a WSDL file.

If a WSDL file cannot be imported, then the file and the file's namespace are crossed out in the Add Import dialog box. This situation can happen for the following reasons:

The WSDL Editor allows you to import a WSDL file that is located in a different project. For more information, see the "About Cross-Project XML File References" topic in the IDE online help.

To import a WSDL file:

  1. In the WSDL view, right-click the Imports node and choose Add WSDL Import.
    The Add Import dialog box opens.
  2. Expand the By File or By Namespace node to navigate to and select the WSDL file.
  3. Click OK.
    The WSDL import node appears.

top

Configuring Messages Using the WSDL View

You can use the WSDL Editor to create, edit, and delete messages.

In a WSDL file, a port type contains one or more related operations that the web service can perform. An operation receives a message, sends a message, or does both.

Each message contains one or more logical parts. For each part, you must specify the name and the type of content.

If you change the name of a message or part, then the WSDL Editor renames all occurrences in the same file. To rename all occurrences in associated XSD, WSDL, and BPEL files as well, right-click the component node and choose Refactor > Rename.

To create a message:

  1. In the WSDL view, right-click the Messages node and choose Add Message.
    A message node appears. The message contains one part. The part's type of content is undefined.
  2. If the Properties window is not visible, choose Window > Properties.
  3. The Element or Type property specifies the type of content. To set the value, click the ellipsis (...) button. The Element or Type dialog box enables you to select any of the built-in types in W3C XML Schema. If you added an inline schema or imported a schema, then you can select an element or type from the schema.

To add a part to a message:

To change the name of a message or part:

  1. If the Properties window is not visible, choose Window > Properties.
  2. Select the message or part node.
  3. Set the Name property to the new name.

To delete a message or part:

  1. Select the message or part node.
  2. Press Delete.

top

Configuring Port Types Using the WSDL View

You can use the WSDL Editor to create, edit, and delete port types.

In a WSDL file, a port type contains one or more related operations that the web service can perform. An example of an operation is GetQuote.

The WSDL Editor supports the following categories of operations:

Each message contains one or more logical parts. For each part, you must specify the name and the type of content.

If you change the name of a port type or operation, then the WSDL Editor renames all occurrences in the same file. To rename all occurrences in associated XSD, WSDL, and BPEL files as well, right-click the component node and choose Refactor > Rename.

To create a port type:

  1. In the WSDL view, right-click the Port Types node and choose Add Port Type.
    The Create New Port Type dialog box appears.
  2. Enter a name for the port type.
  3. Enter a name for the operation.
  4. Select the category of operation.
  5. Define the message that the operation receives as input. You can create a message from scratch by entering a new message name in the drop-down list, or you can select an existing message from the drop-down list. For a new message, the Add and Remove buttons enable you to add and remove message parts.
  6. If the operation is a request-response operation, then define the message that the operation sends as output.
  7. (Optional) If the operation is a request-response operation, then you can define a message that the operation sends as a fault.
  8. Click OK.
    A port type node appears. The port type node contains an operation node. If you created one or more messages, then the message nodes appear. In addition, a partner link type is automatically created.

To add an operation to an existing port type:

  1. In the WSDL view, right-click the port type node and choose Add > Operation.
    The Create New Operation dialog box appears.
  2. Enter a name for the operation.
  3. Select the category of operation.
  4. Define the message that the operation receives as input. You can create a message from scratch by entering a new message name in the drop-down list, or you can select an existing message from the drop-down list. For a new message, the Add and Remove buttons enable you to add and remove message parts.
  5. If the operation is a request-response operation, then define the message that the operation sends as output.
  6. (Optional) If the operation is a request-response operation, then you can define a message that the operation sends as a fault.
  7. Click OK.
    An operation node appears. If you created one or more messages, then the message nodes appear.

To add a fault to a request-response operation:

  1. If the Properties window is not visible, choose Window > Properties.
  2. Right-click the operation node and choose Add > Fault.
    The fault node appears.
  3. Set the Message property to the fault message.

To change the name of a port type or operation:

  1. If the Properties window is not visible, choose Window > Properties.
  2. Select the port type or operation node.
  3. Set the Name property to the new name.

To change the parameter order of an operation:

  1. If the Properties window is not visible, choose Window > Properties.
  2. Select the operation node.
  3. Click the ellipsis (...) button for the Parameter Order property.
    The Parameter Order dialog box appears.
  4. Move message parts from the Available Parameters list to the Current Parameters list.
  5. Arrange the parts in the desired order.
  6. Click OK.

To delete a port type or operation:

  1. Select the port type or operation node.
  2. Press Delete.

top

Configuring Bindings Using the WSDL View

You can use the WSDL Editor to create, edit, and delete bindings.

binding example in WSDL view of WSDL Editor

In a WSDL file, a binding contains protocol and data format information for the operations and messages of a port type.

The WSDL view provides the following approaches:

If you change the name of a binding, then the WSDL Editor renames all occurrences in the same file. To rename all occurrences in associated XSD, WSDL, and BPEL files as well, right-click the binding node and choose Refactor > Rename.

To create a binding and service from a port type:

  1. In the WSDL view, right-click the port type node and choose Add > Binding and Service Port.
    The Generate Binding and Service Port dialog box appears.
  2. Enter a name for the binding.
  3. Select the type of binding.
  4. Select the binding subtype. The choices vary depending on the binding type.
  5. Enter a name for the service.
  6. Enter a name for the port.
  7. Click OK.
    A binding node and a service node appear.
    The binding node contains an extensibility element (for example, file:binding) that identifies the type of binding. The binding node also contains one or more operation nodes.
    The service node contains a port node. The port node contains an address extensibility element (for example, file:address).
  8. For information on how to configure the extensibility elements of the binding and service, see the appropriate binding component user's guide.

To create a binding individually:

  1. In the WSDL view, right-click the Bindings node and choose Add Binding.
    A binding node appears.
  2. If the Properties window is not visible, choose Window > Properties.
  3. Select the binding node.
  4. (Optional) Change the value of the Name property.
  5. Set the Type property to the port type that the binding will reference.
  6. Right-click the binding node, point to Add, and choose the desired binding type (for example, File Binding).
    A node that identifies the binding type appears.
  7. Right-click the binding node and choose Add > Binding Operation.
  8. If the binding's port type has more than one operation, then the Select Operation dialog box appears. Choose one or more operations, and click OK.
    One or more operation nodes appear.
  9. For information on how to configure the binding's extensibility elements, see the appropriate binding component user's guide.

To delete a binding:

  1. Select the binding node.
  2. Press Delete.

top

Configuring Services Using the WSDL View

You can use the WSDL Editor to create, edit, and delete services.

service example in WSDL view of WSDL Editor

In a WSDL file, a service consists of one or more related ports. Each port associates a binding with a network address, thus defining an individual endpoint that clients can access.

The WSDL view provides the following approaches:

To create a binding and service from a port type:

  1. In the WSDL view, right-click the port type node and choose Add > Binding and Service Port.
    The Generate Binding and Service Port dialog box appears.
  2. Enter a name for the binding.
  3. Select the type of binding.
  4. Select the binding subtype. The choices vary depending on the binding type.
  5. Enter a name for the service.
  6. Enter a name for the port.
  7. Click OK.
    A binding node and a service node appear.
    The binding node contains an extensibility element (for example, file:binding) that identifies the type of binding. The binding node also contains one or more operation nodes.
    The service node contains a port node. The port node contains an address extensibility element (for example, file:address).
  8. For information on how to configure the extensibility elements of the binding and service, see the appropriate binding component user's guide.

To create a service individually:

  1. In the WSDL view, right-click the Services node and choose Add Service.
    A service node appears.
  2. If the Properties window is not visible, choose Window > Properties.
  3. Select the service node.
  4. (Optional) Change the value of the Name property.
  5. Right-click the service node and choose Add > Service Port.
    A port node appears.
  6. Select the port node.
  7. (Optional) Change the value of the Name property.
  8. Set the Binding property to the desired binding.
  9. Right-click the port node and add the address extensibility element (for example, File Address).
  10. For information on how to configure the address extensibility element, see the appropriate binding component user's guide.

To delete a service or port:

  1. Select the service or port node.
  2. Press Delete.

top

Configuring Partner Link Types Using the WSDL View

A partner link type characterizes the conversational relationship between two services. A partner link type can have one role or two roles.

A role describes the function that a partner has in the relationship. For example, in a procurement scenario, the partner link type could have two roles: Buyer and Seller.

A role must specify the port type that the service will use to receive messages.

To add a partner link type automatically

  1. When you do either of the following tasks, a partner link type is automatically generated. The partner link type has a default role.
    • Create a WSDL file from scratch.
    • Create a port type.
  2. (Optional) To add a second role, do the following:
    1. Right-click the partner link type node and choose Add > role.
    2. If the Properties window is not visible, choose Window > Properties.
    3. Select the role.
    4. (Optional) Change the default name.
    5. Specify the port type.

To add a partner link type manually:

  1. In the WSDL view, right-click the Extensibility Elements node and choose Add > PartnerLinkType.
    A partner link type node appears under the Extensibility Elements node. The partner link type has a default role.
  2. (Optional) To add a second role, right-click the partner link type node and choose Add > role.
  3. If the Properties window is not visible, choose Window > Properties.
  4. For each role, do the following:
    1. Select the role.
    2. (Optional) Change the default name.
    3. Specify the port type.

top

Configuring Properties and Property Aliases Using the WSDL View

The BPEL Service Engine uses a mechanism called correlation to track the multiple, stateful, long-running exchanges of messages that typically take place between a BPEL process and its partner services.

The procedure for enabling correlation in a BPEL process includes the following initial steps, which must be performed in the WSDL file:

Once you perform these steps in the WSDL file, you can create a correlation set in the BPEL process. The correlation set references one or more properties. The correlation set can then be used by message activities (Invoke, Reply, and Receive) and by the onMessage branches of Pick elements.

To add a property to a WSDL file:

  1. In the WSDL view, right-click the Extensibility Elements node and choose Add > Property.
    A property node appears under the Extensibility Elements node.
  2. If the Properties window is not visible, choose Window > Properties.
  3. Select the property node.
  4. Set the name property.
  5. You can set the ElementOrType property to a built-in simple type, such as string or date. If you added an inline schema or imported a schema, then you can select a type from the schema.

To add a property alias to a WSDL file:

  1. In the WSDL view, right-click the Extensibility Elements node and choose Add > Property Alias.
    A property alias node appears under the Extensibility Elements node.
  2. If the Properties window is not visible, choose Window > Properties.
  3. Select the property alias node.
  4. Specify values for the propertyName and ElementOrTypeOrMessagePart properties. These properties enable you to map data from a message into a property value.
  5. To add a query, right-click the property alias node and choose Add > query.
    A query node appears. The query node enables you to set the query language and the text of the query.

top

Finding Usages of WSDL Components

You can quickly determine where a WSDL component is used in the WSDL file.

To find usages of a WSDL component:

  1. In the WSDL view, right-click the component and choose Find Usages.
    The Usages window opens in the lower part of the IDE. The window has three parts:
    • Toolbar. The toolbar buttons let you refresh information in the window, expand and collapse nodes in the tree pane, and cycle through the found usages.
    • Tree pane. The tree pane contains nodes for the results of the query.
    • Graph pane. The graph pane shows a graphical representation of the results.
  2. To zoom out, right-click in the graphic and drag up. To zoom in, right-click in the graphic and drag down.
  3. To pan, click and drag in any direction.
  4. To drag a node, click and drag the node.

top

Adding Documentation

You can add documentation to any WSDL language element.

To add documentation:

  1. In the WSDL view, right-click an element and choose Add > Documentation.
    A documentation node appears.
  2. If the Properties window is not visible, choose Window > Properties.
  3. Select the documentation node.
  4. Enter the documentation text.

top

Using Find in the WSDL View

You can search for WSDL components in the current WSDL file.

You can define the type of find to be performed:

For more information about regular expressions, see the "Regular Expressions For Finding and Replacing Text" topic in the IDE online help.

To search for WSDL components:

  1. From from the IDE's main menu, choose Edit > Find. You can also press Ctrl-F.
    The Find bar opens at the bottom of the WSDL view.
  2. In the Find box, click the magnifying glass icon and select the type of search that you want to perform: Component Name, Component Kind, Attribute Declaration, or Attribute Value.
  3. If you want to find matches from a specific point, then select a component in the WSDL view, click the magnifying glass icon, and select Search Selection.
  4. If you want to use a regular expression, then click the magnifying glass icon and select Use regular expression.
  5. In the Find box, type the text or regular expression and press Enter.
    The IDE finds any matching components and highlights the matches in the WSDL view.
  6. To cycle through the matching components, use the Find Next and Find Previous buttons.

To clear highlights after a search:

top

Partner View

The Partner view of the WSDL Editor represents the abstract elements of a WSDL file as interactions between partners.

The abstract elements include partner link types, roles, port types, operations, and messages.

A partner link type characterizes the conversational relationship between two services. A role describes the function that a service has in the relationship. A partner link type can have one role or two roles.

A role must specify the port type that the service will use to receive messages. A port type contains one or more related operations that the web service can perform. The WSDL Editor supports the following categories of operations:

The concrete elements of a WSDL file (that is, bindings and services) describe how to invoke the functionality defined by the abstract elements. Creating a WSDL file that contains only abstract elements is an effective design approach. You can define the concrete elements at deployment time by using the Composite Application Service Assembly (CASA) editor. Thus, if you need to change the bindings at some point, you can do so without modifying the project.

top

Strategies for Defining the Abstract Elements

In the Partner view of the WSDL Editor, you can define the abstract elements by starting with the partner interactions or by starting with the messages that are exchanged by the partners.

To define the abstract elements by starting with the partner interactions:

  1. Create a partner link type. The partner link type contains a default role, which appears on the right. If you want to define a peer-to-peer interaction, then you must add a second role on the left.
  2. Choose or create the port types and operations.
  3. Create the messages that will be sent from one partner to another.
  4. Assign the messages to the partner link type's operations.
  5. Specify the data types for the message parts. Note that you can create or import an XML schema by using the Navigator window, and then drag the schema elements or types into the messages.

To define the abstract elements by starting with the messages:

  1. Create or import an XML schema by using the Navigator window.
  2. Create the messages that will be sent from one partner to another. Note that you can drag the schema elements or types from the Navigator window into the messages.
  3. Create a partner link type. The partner link type contains a default role, which appears on the right. If you want to define a peer-to-peer interaction, then you must add a second role on the left.
  4. Choose or create the port types and operations.
  5. Assign the messages to the partner link type's operations.

top

Partner View Layout

The Partner view of the WSDL Editor has the following components:

You can expand or collapse the configuration boxes. When a box is collapsed, click the downward arrow to expand the box. When a box is expanded, click the upward arrow to collapse the box.

The IDE's Navigator window provides a compact view of the currently selected file and simplifies navigation between different parts of the file. For WSDL files, the Navigator has two views: WSDL and XML.

The WSDL view of the Navigator window is identical to the WSDL view of the WSDL Editor.

WSDL view of Navigator window

The XML view uses a tree structure to represent the XML tags in the WSDL file.

XML view of Navigator window

To display the Navigator, choose Window > Navigator from the IDE's main menu.

top

Navigating in the Partner View

You can perform the following tasks from the toolbar of the Partner view:

Partner view toolbar

If you right-click a component and choose Go To > Source, then the Source view appears with the cursor positioned at the beginning of the component's block.

If you right-click a component and choose Go To > WSDL, then the WSDL view appears with the appropriate node highlighted.

After performing an action in the Partner view, you can reverse the action by choosing Edit > Undo (Ctrl-Z) from the IDE's main menu. You can reverse an undo command by choosing Edit > Redo (Ctrl-Y) from the IDE's main menu.

You can print the contents of the Partner view by using the IDE's standard print feature.

top

Creating Partner Link Types Using the Partner View

The Partner Link Types area in the Partner view contains one configuration box for each partner link type in the WSDL file.

configuration box for a partner link type
Click to enlarge

A partner link type can have one role or two roles. The first role appears in the right side of the configuration box. If included, the second role appears in the left side of the configuration box.

The role's port type appears below the role. A port type has one or more operations, which are illustrated in the area below the port types. A solid horizontal arrow indicates an input message. A dashed horizontal arrow indicates an output message.

If the operation is a request-response operation, then you can optionally add a fault. A dashed horizontal arrow indicates a fault message.

Partner link types from imported WSDL files do not appear in the Partner view.

To create a partner link type with one role:

  1. Do one of the following:
    • Click Add Partner Link Type.
    • Drag the Partner Link Type icon from the Palette onto a blank portion of the Partner Link Types area.
    • Right-click a blank portion of the Partner Link Types area and choose Add PartnerLinkType.
    The configuration box for the partner link type appears. The partner link type contains a default role.
  2. In the right side of the configuration box, specify the port type that the service will use to receive messages. To create a new port type, double-click Enter or Select a Port Type and enter the name. To use an existing port type, click Enter or Select a Port Type and select the port type from the drop-down menu.
  3. If you created a new port type, or if you want to add one or more operations to an existing port type, then do the following:
    1. Drag one or more operations from the Palette onto the dashed vertical line that extends below the port type.
    2. For each operation, select the messages. You can double-click <No Message Selected> and select a message from the drop-down list. Alternately, you can drag a message from the Navigator window onto <No Message Selected>.

To add a second role to a partner link type:

  1. In the left side of the configuration box, double-click [External Partner] and enter the role name.
  2. In the left side of the configuration box, specify the port type that the service will use to receive messages. To create a new port type, double-click Enter or Select a Port Type and enter the name. To use an existing port type, click Enter or Select a Port Type and select the port type from the drop-down menu.
  3. If you created a new port type, or if you want to add one or more operations to an existing port type, then do the following:
    1. Drag one or more operations from the Palette onto the dashed vertical line that extends below the port type.
    2. For each operation, select the messages. You can double-click <No Message Selected> and select a message from the drop-down list. Alternately, you can drag a message from the Navigator window onto <No Message Selected>.

To add a fault to a request-response operation:

  1. Right-click the operation name and choose Add Fault.
    The fault appears.
  2. Double-click <No Message Selected>.
  3. Select the fault message.

top

Editing Partner Link Types Using the Partner View

The Partner Link Types area in the Partner view enables you to modify or delete the partner link types, roles, port types, and operations in a WSDL file.

To change the name of a partner link type, role, port type, or operation:

  1. Double-click the partner link type name, role name, port type name, or operation name.
  2. Change the name.
  3. Press Enter.

To delete an operation:

To delete a port type:

To delete a role:

To delete a partner link type:

top

Creating Messages Using the Partner View

The Messages area in the Partner view contains one configuration box for each message in the WSDL file.

configuration boxes for two messages

In a WSDL file, a port type contains one or more related operations that the web service can perform. An operation receives a message, sends a message, or does both.

Each message contains one or more logical parts. For each part, you must specify the name and the type of content.

To create a message:

  1. Do one of the following:
    • Click Add Message.
    • Drag the Message icon from the Palette onto a blank portion of the Messages area.
    • Right-click a blank portion of the Messages area and choose Add Message.
    The configuration box for the message appears. The message contains one part. The part's type of content is undefined.
  2. Do one of the following:
    • In the Part Element or Type column, click the ellipsis (...) button. Select any of the built-in types in W3C XML Schema. If you added an inline schema or imported a schema, then you can select an element or type from the schema. Click OK.
    • Drag an element or type from the Navigator window onto the Part Element or Type column.

To add a part to a message:

top

Editing Messages Using the Partner View

The Messages area in the Partner view enables you to modify or delete the messages in a WSDL file.

To change the name of a message:

  1. Double-click the message name.
  2. Change the name.
  3. Press Enter.

To change the name of a part:

  1. In the Part Name column, double-click the part name.
  2. Change the name.
  3. Press Enter.

To change the type of content for a part:

To delete a part:

To delete a message:

top

Working with WSDL Files

Creating a WSDL File From Scratch

When you create a WSDL file from scratch, the wizard contains three pages that you can fill out.

You do not need to complete all three pages. You can fill out the Name and Location page and then click Finish. Or you can fill out the Name and Location page and the Abstract Configuration page and then click Finish.

To create a WSDL file from scratch:

  1. In the Projects window, right-click the Process Files node and choose New > WSDL Document.
  2. In the Name and Location wizard page, do the following:
    1. Enter a name for the file. The name must comply with the rules for the NCName data type. You cannot enter a name that already exists in the project.
    2. (Optional) Change the default folder by clicking Browse and selecting the new folder.
    3. Enter the target namespace for the WSDL file. The target namespace will appear in the root element.
    4. Specify any XML Schema files that you want to import.
    5. If you want to configure the abstract and concrete information from the wizard, then click Next. Otherwise, click Finish.
  3. In the Abstract Configuration wizard page, do the following:
    1. Enter a name for the port type.
    2. Enter a name for the operation.
    3. Select the category of operation.
    4. Define the message that the operation receives as input.
    5. If the operation is a request-response operation, then define the message that the operation sends as output.
    6. (Optional) If the operation is a request-response operation, then you can optionally define a message that the operation sends as a fault.
    7. If you want to configure the concrete information from the wizard, then click Next. Otherwise, click Finish.
  4. In the Concrete Configuration wizard page, do the following:
    1. Enter a name for the binding.
    2. Select the type of binding.
    3. Select the binding subtype. The choices vary depending on the binding type.
    4. Enter a name for the service.
    5. Enter a name for the port.
    6. Click Finish.
    The WSDL file is created. The WSDL Editor appears in WSDL view.

top

Creating a WSDL File Based On an Existing WSDL File

Instead of creating a WSDL file from scratch, you can create a WSDL file based on an existing WSDL file.

To create a WSDL file based on an existing WSDL file:

  1. In the Projects window, right-click the Process Files node and choose New > Other.
  2. In the Choose File Type wizard page, do the following:
    1. In the Categories list, select the XML node.
    2. In the File Types list, select the External WSDL Document(s) node.
    3. Click Next.
  3. In the Specify Resource Location wizard page, do one of the following:
    • To create a WSDL file based on a running service:
      1. Select the From URL button.
      2. Enter the URL of the service's WSDL file.
      3. Click Finish.
    • To create a WSDL file by using an existing WSDL file on the local file system:
      1. Select the From Local File System button.
      2. Specify the folder where the WSDL file is located.
      3. Click Finish.
    The WSDL file is created. The WSDL Editor appears in WSDL view.

top

NCNAME Data Type

XML Schema includes a data type called NCName. Any name that has the NCName data type must comply with the following rules:

top

Using Refactoring to Rename or Delete WSDL Components

You can perform refactoring by using the following approaches:

Menu that shows the refactoring options

You can also rename a component by changing the value of the Name property. The WSDL Editor renames all occurrences in the same file, but not in other files.

top

Validating WSDL Files

The WSDL Editor includes a validation tool. The validation tool reviews the WSDL file for problems with syntax and semantics.

To validate a WSDL file:

  1. Display any of the views in the WSDL Editor.
  2. In the toolbar, click the Validate XML button.
    The Output window displays any errors or warnings.

top

See Also



Send Us Your Feedback

top

www.000webhost.com